Ostatnio aktualizując Compiz i dokonując zmiany sterowników nvidia na proponowane przez Ubuntu (nvidia-cerent >> przebudowane sterowniki 190.53), straciłem animacje. Cały compiz działa, tylko tego jednego znaczącego aspektu wizualnego nie ma. Na Arch linux compiz nie miałem takich przypadłości, dlatego myśląc że to wina aktualizacji, wykonałem instalacje wcześniejszych paczek. Ale problem się nie rozwiązał. Dzisiaj, mając dość nie działających animacji, zakończyłem w Terminal-u proces compiz i uruchomiłem go ponownie. Jakie było moje zdziwienie kiedy okazało się że plugin: Animacja, powodują błąd:
compiz (core) – Error: Couldn’t load plugin ‚/usr/lib/compiz/libanimation.so’ : libGLU.so.1: cannot open shared object file: No such file or directory
compiz (core) – Error: Couldn’t load plugin ‚animation’

Więc wykonałem wizytę na witrynie: http://packages.ubuntu.com/ i wyszukałem, w jakiej paczce znajduje się plik libGLU.so . Jak się okazało, ten plik zawiera się w paczce: libglu1-mesa. Więc zaktualizowałem compiz do najnowszej wersji i obniżyłem wersję paczki libglu1-mesa do 7.6.0, oraz dla zasady mesa-utils. Nawet nie restartowałem compiz, wystarczyło uruchomić: ccsm (panel ustawień compiz) i zahaczyć „Animacje”, które uruchomiły się momentalnie 🙂 Teraz wreszcie mogę się cieszyć pełnym compiz.
———
Obecnie po ukazaniu się 17.01.2010r. aktualizacji libglu1-mesa w wersji 7.7-0ubuntu6, problem z niedziałającymi animacjami znikł. Dzisiaj też ukazała się aktualizacja sterowników do nvidia 190.53, co też może skutkować naprawą tego błędu.

Reklamy

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj / Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj / Zmień )

Zdjęcie na Google+

Komentujesz korzystając z konta Google+. Wyloguj / Zmień )

Connecting to %s