chrome/chromium na ubuntu 10.04 64 bit
Adobe Flash 64 bit – download
Chromium:
sudo cp /home/xxx/Desktop/libflashplayer.so /usr/lib/chromium-browser/plugins/

chrome:
sudo cp /home/xxx/Desktop/libflashplayer.so /opt/google/chrome/plugins/
xxx — nazwa konta
chrome/chromium na ubuntu 10.04 64 bit

Prawdopodobnie za nie działający flash adobe odpowiadają:
— libgtk2.0-common
— libgtk2.0-bin
— libgtk2.0-0
— libgail18
— libgail18-common
— gtk2-engines-pixpaf
i wszystkie powiązana związane z tymi paczkami…
Po cofnięciu wersji wyżej wymienionych paczek: flash w całym systemie zaczyna działać.

Od jakiegoś tygodnia moje chrome jak i chromium odmawiają używania wtyczki flash adobe, ukazując błąd tej że wtyczki. Nie było by w tym nic dziwnego gdyby nie to, że te same elementy przed załadowanie się strony działają właściwie.
Po przeczesaniu internetu okazuje się, że co wiedziałem ale u mnie to działało właściwie, że „w środku” chrome, jak i prawdopodobnie chromium została „włożona” obsługa flash. I to też nie było by dziwne gdyby nie fakt, że jak podaje strona chrome dev:

An integrated Adobe Flash Player Plug-in. We’re integrating Adobe Flash Player 10.1.51.95 (10.1 beta 3) with Google Chrome so that you don’t have to install it or worry about keeping it up-to-date.

już tłumaczę: programiści google integrują chrome z najnowszym wydaniem adobeflash 10.1, więc nie mamy się martwić o jego instalację i aktualizację.
super, prawda….?
NIE, Adobe Flash 10.1 JEST TYLKO 32bit… więc czytamy dalej:

There is no bundled Adobe Flash Player plug-in for 64-bit Linux.

Nie ma pakietu Adobe Flash Player plug-in do 64-bitowego systemu Linux.
czyli wszem i wobec systemy linux w wersji 64 bit, zostały kopnięte w tyłek z obsługą flash-a.
Programiści zaznaczają, że można uruchomić wewnętrzną wtyczkę flash, poleceniem: --enable-internal-flash

Przeglądarka chrome i chromium umie obecnie korzystać z wtyczki flash adobe, które są rozlokowane po systemie, np. firefox lub zainstalowana z repo dystrybucji, tylko że posiadając system 64 bit, obie te przeglądarki nie umieją uruchomić żadnej wtyczki, a werja 32 bit, nie jest przez nie wykrywana (czyt. widziana).

To i tak nie jest jeszcze nic, ponieważ możemy sprawdzić z jakich wtyczek i gdzie one się znajdują korzysta chrome i chromium: about:plugins

chrome w obecnej wersji wprowadził obejście problemów z flashadobe na systemach linux:

Flash content when using nspluginwrapper should be clickable again.

co oznacza, że jeśli wtyczka ma problem z flash na stronie, uruchomi go przez nspluginwrapper.
A każdy zaznajomiony użytkownik systemu linux nie instaluje flash adobe z repo i pierwsze co, to kasuje wyżej wspomniany pakiet.

obecnie czytamy:

Flash enabled by default

…co oznacza, że wyżej wymienione polecenie włączające wewnętrzną obsługę flash, jest już nam nie potrzebne, ponieważ wewnętrzna zintegrowana obsługa flash działa od momentu uruchomienia przeglądarki. Teraz by się przydała komenda wyłączająca tą obsługę 🙂

dlatego mój chrome czeka na wprowadzenie wtyczki 64 bit, ale jak wiadomo wersja flash 10.1 jeszcze długi będzie czekać na 64 bit jej odmianę, więc i mój chrome będzie się borykać z problemami braku elementów flash na stronach.

—————-

Proszę o komentarz, jeśli komuś kto posiada wersję systemu 64 bit, udało się naprawić lub działa u niego flash na stronach w przeglądarce chrome dev, nie chodzi mi o wersję beta.

Reklamy

6 myśli na temat “chromium/chrome i flash adobe (aktualizacja)

  1. Mam Chrome 6.0.401.1 i Flasha 10.0 r45 (jakaś alpha) w ~/.mozilla/plugins, wszystko 64-bitowe. Nigdy nie miałem z takim rozwiązaniem problemów, nie mam ich też po ostatniej aktualizacji Chrome.

    Polubienie

    1. mam tą samą wersję 64 bit flash-a….

      i na arch linux, ta sama wersja flash 64 bit, bo system też jest 64 bit, i ta sama wersja chrome, okazuje się że wszystko działa dobrze…

      … więc już sam nie wiem, może to coś w systemie

      Polubienie

  2. Jak instalujecie nową wersję Chromium na Linuksie, wywalcie katalogi usera:

    .config/chromium
    .cache/chromium

    I wszystko od razu śmiga jak trzeba… Tam Chromium ma swoje stare ustawienia!
    Rzecz dotyczy aktualizowania bardzo wielu programów do nowej wersji!!!

    Polubienie

  3. sprawdzałem i nie pomogło, ponieważ flash adobe, nie działał także w firefox i chrome. A aktualizacja podanych wyżej paczek, powodowało brak obsługi adobe flash, dopiero cofnięcie się do wersji 2.20 – naprawiło wszystko.
    Ponieważ pierwsze co wykonałem to właśnie czyszczenie ustawień, co nie pomogło.

    Polubienie

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj / Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj / Zmień )

Zdjęcie na Google+

Komentujesz korzystając z konta Google+. Wyloguj / Zmień )

Connecting to %s