Na co trzeba uważać przy aktualizacji:
— xorg i xserver
— sterowniki nVidia (jeśli ktoś posiada taką kartę graficzną)
— gnome (ustawienia)
— paczki nie wspierane i całkiem nowe paczki

Z doświadczenia z poprzednich wydań wiem, że aktualizacja z poziomu działającego systemu to lipa i pic na wodę: nie działające urządzenia, nie działająca grafika, nie do końca działające ustawienia itd.

Moja rada: chcesz robić aktualizację, zrób to ale bez uruchamiania pulpitu, czyli ładujemy system do poziomu czarnego ekranu i poleceń.
Kolejna rzecz, przed wykonaniem aktualizacji, kasujemy/zmieniamy nazwy wszystkich ustawienia w katalogu /home/xxx zostawiając rzeczy, które nie są ustawieniami: zdjęcia, pulpit, czy ściągnięte pliki.
Ponieważ zmiany zastosowane w nowych paczkach w 90% nie są kompatybilne.

Trzeba też liczyć się z tym, że system nam się nie uruchomi po aktualizacji z poziomu działającego pulpitu.

Następną rzeczą, którą trzeba zrobić po aktualizacji, to przeinstalowanie całego systemu, a nie jest to ani proste, ani miłe.

Wiele osób miesza różne paczki, od różnych osób np. używa paczek z launchpad.net , które nie są czasami tworzone z zależnościami, które powinny być. Tu mogę przytoczyć przykład paczki pidgin-a z getdeb, które nie zawierały w sobie obsługi w gmail obrazu i głosu, choć paczki od Ubuntu, czy pidgin developer, miały tą obsługę.

Kolejną rzeczą, która została zmieniona, to przejście Ubuntu całkowicie na pulseaudio, więc jeśli posiadamy ustawienia pod stare rozwiązanie, może nam głos nie działać.

Problemem też mogą być paczki wcześniej wspierane przez Canonical, a po aktualizacji, przestają one być odnawiane, poprawiane, co może też na spożyć trochę problemów, bo może się okazać, że jakiś program może generować błąd, albo źle działać.
np. u mnie imagination, program do filmików działał, ale po zainstalowaniu paczek z mediubuntu, program nie umiał dodać muzyki do obrazu, po powrocie do oryginalnych paczek od Canonical, wszystko wróciło do normy.

—-
Jak widać, powodem problemów po aktualizacji Ubuntu, może być wiele, choć zazwyczaj są to ustawienia i konflikt tych ustawień pod względem nowych rozwiązań zawartych w nowych paczkach i blokada opcji, które wcześniej działały lub były wykorzystywane.

Reklamy

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj / Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj / Zmień )

Zdjęcie na Google+

Komentujesz korzystając z konta Google+. Wyloguj / Zmień )

Connecting to %s