Po ponad 6 miesiącach chcąc uaktualnić swojego arch linux postanowiłem naprawić błąd, który zaczął trapić mój system. A mianowicie mowa o nie możliwości aktualizacji, przez błąd pliku liblzma.so.0, którego pacman nie umiał znaleźć. Mając możliwość przejścia do linii poleceń (ponieważ żaden z pulpitów nie umiał się uruchomić) dowiedziałem się, że pojawiła się nowa wersja Pacman-a, a arch linux przeszedł na paczki .xz i aby korzystać z aktualizacji muszę posiadać w systemie paczkę „xz”. Aby ją zdobyć uruchomiłem elinks (przeglądarka tekstowa, działająca w terminalu) i wszedłem na http://www.archlinux.org/packages/core/x86_64/xz/ ( wersja 32bit >> http://www.archlinux.org/packages/core/i686/xz/) i ściągnąwszy moją wersję „Download From Mirror„, czyli 64 bit, wykonałem polecenie:
sudo tar -xvpf xz-4.999.9beta-5-x86_64.pkg.tar.gz -C / --exclude .PKGINFO --exclude .INSTALL

(wersja 32 oczywiście wystarczy zmienić x86_64 na i686.
I wtedy dopiero pacman, po wydaniu poleceniu pacman -Syu wykonał sprawdzenie źródeł i wykonał aktualizację pacman-a jak i całego systemu.
Okazało się, że arch linux przeszzedł na nouweau, gdzie zastępuje sterowniki nouveau-drm na kernel26…
Widać arch linux w przeciągu 4 misięcy przeszedł dość ciekawą modernizację, zobaczymy co będzie dalej.

ps.
z tego co się dowiedziałem z internetu to to, że chakra odłączył się od arch linux, nie wiem czy to dobrze czy źle, to się okaże.

Reklamy

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Wyloguj / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Wyloguj / Zmień )

Zdjęcie na Facebooku

Komentujesz korzystając z konta Facebook. Wyloguj / Zmień )

Zdjęcie na Google+

Komentujesz korzystając z konta Google+. Wyloguj / Zmień )

Connecting to %s