Posiadając Ubuntu muszę się liczyć z tym, że nie wszystkie paczki będę miał na swój system w wersji najnowszej. Ubuntu jest prosty i za to go wiele ludzi uwielbia. Ja jednak chcąc trochę się pomęczyć z systemem, posiadam na laptopie także Arch linux, który nie jest tak popularny jak gentoo czy debian, ale trzeba się trochę napocić aby zrozumieć działanie systemu i skonfigurować go.

Chcąc sprawdzić, jak prezentuje się się najnowsze wydanie Kadu, które posiada obsługę jabber-a i zostało przebudowane – byłem zmuszony zrobić to pod Arch linux 🙂 Tym bardziej to mnie ucieszyło, że społeczność zgromadzona koło arch-a dała już kadu beta6.
Za co pokochałem Arch-a, to właśnie pacman i yaourt, które odwalają za mnie całą pracę (czyt. kompilacja, tworzenie paczek). W AUR znajdują się paczki, które trzeba tworzyć od podstaw, a w tym przypadku wystarczy wydanie polecenia instalacji, a yaourt sam ściągnie potrzebne zależności LUB SOBIE JE STWORZY, pobierając odpowiednie pliki. Nie straszne mu svn, git, kompilacja. Wszystko dzieje się bez naszego udziału, program sam wszystko zrobi. Problem pojawia się, kiedy wyskakuje błąd, ale i z tym umiem sobie w miarę wiedzy poradzić 🙂
Przechodząc do Kadu, tworzenie paczek zajmuje trochę czasu. Trzeba także przygotować się na to, że pojawi się błąd zależności. U mnie polegał on na dograniu paczki: phonon.
Ogólnie kadu się pozmieniało, ale nie na tyle aby była to rewolucja…
Przebudowano menu, które spełnia obecnie standardy.

lista…

tak wygląda nowe kadu… dodano avatary na listę kontaków, wreszcie i po najechaniu widzimi opis, a nie stan kontaktu. Martwi mnie to, że wtyczka „kto ma nas na liście” została wyrzucona.
Nowe Kadu nie zachwyciło mnie, to po prostu program jaki powinnien być od jakiegoś roku.
Ale dobrze, że chociaż tyle zostało zrobione 🙂
Przed nami prawdopodobnie jeszcze trochę czasu, zanim wszystkie błędy zostaną naprawione.

Aby przetestować kadu 0.6.6beta6 wystarczy w Terminalu wydać polecenie:
sudo yaourt -S kadu-devel
Jeśli pojawią się braki w paczkach, zostaniemy o tym powiadomieni, aby je zainstalować.
miłego testowania… 🙂
chcąc posiadać najnowsze wydanie, można edytować PKGINFO.
Zmieniamy wpis beta6 na beta7 (u góry i przy nazwie pliku). Teraz wklejamy nową sumę kontrolną:
7b9a3597aa75f4c041d91c44f27e2b04
Zapisujemy plik i potwierdzamy dalszą instalacje. Po utworzeniu paczki i instalacji, cieszymy się nową betą Kadu 🙂

Advertisements

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Log Out / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Log Out / Zmień )

Facebook photo

Komentujesz korzystając z konta Facebook. Log Out / Zmień )

Google+ photo

Komentujesz korzystając z konta Google+. Log Out / Zmień )

Connecting to %s