==aktualizacja ==
Poniższy tekst jest już nie aktualny 🙂 w repozytoriach pojawiły się sterowniki do kart graficznych nvidia – 270.x – co naprawia błąd ich instalacji.
xorg obecnie już powinien działać.
Jeśli masz problemy z grafiką, spróbują ją uruchomić na innych sterownikach np. nouveau, albo nv lub vesa. Jeśli nadal coś nie działa. Skasuj całkiem xserver i xorg i zainstaluj ponownie. Podobnie wykonaj ze sterownikami nvidia.
Jeśli system zatrzymuje się w pewnym momencie, a gdm czy inny manager logowania się nie pojawia. Przełącz się na inny terminal (jeśli będziesz mógł) i zaloguj się na konto. Teraz to już dość prosta droga do reinstalacji sterowników czy elementów systemu 🙂
===================================

Mowa tylko o wersji Ubuntu 11.04 natty…
Wczoraj dokonałem aktualizacji serwera xorg (xserver), który zaznaczył mi do skasowania sterowniki do karty graficznej nvidia-current. A że była to aktualizacja Ubuntu dokonałem jej. Jakie było moje zdziwienie, gdy okazało się, że sterowniki nvidia nie dadzą się zainstalować. Więc pozostało uruchomić system na nouveau…

Okazuje się jednak, że na Ubuntu są sterowniki nvidia 270.18 (beta).
STEROWNIKI JEDNAK NIE POTRAFIŁY URUCHOMIĆ SERWERA X!!!!

Po krótkim zastanowieniu doszedłem do wniosku, że Canonical przygotowuje nową wersję „sterów” nvidia w wersji 270.18.
Powód jest bardzo prosty:
— dodanie wsparcia dla xserver 1.10
— naprawiono kilka błędów związanych z akceleracją sprzętową gradientu, które były przyczyną braków w niektórych domyślnych motywach Ubuntu – GNOME.

Ta informacja na stronie nvidia pod wersją serowników, może wskazywać, że twórcy Ubuntu pracują nad wdrożeniem nowej wersji current do Ubuntu 11.04. Inaczej, dziwne było by to, że Canonical nie odnowiło sterowników 260.xx – które otrzymały nową wersję.

Więc teraz labo w repo natty ukarzą się sterowniki nvidia 270.18, albo zostanie prowadzony nowy sterownik nouveau, ponieważ bez current nie ma efektów w compiz, a tym samym Unity nie działa.

A jeśli ktoś chce sobie sprawdzić 270.18 w terminalu wkleja: ppa:xorg-edgers/ppa
Ale ostrzegam, AKTUALIZACJA POWODUJE SKASOWANIE XSERVER I XORG!!!! – więc nawet jeśli, to X-y wam się nie uruchomią!!!! Chyba że dokonujecie aktualizacji drm, mesa i xorg, xserver. U mnie system się nie załadował…!!

Advertisements